Delayed LanguageIQ Scores
Incident Report for HireIQ
Resolved
All LanguageIQ scores should now be available.
Posted Jul 26, 2017 - 13:17 EDT
Investigating
Some LanguageIQ scores are temporarily delayed due to an issue with an upstream provider. Missing scores should be available shortly.
Posted Jul 26, 2017 - 12:38 EDT