Possible Connectivity Issues
Incident Report for HireIQ
Resolved
Everything should be back to normal
Posted Feb 11, 2015 - 15:54 EST
Investigating
We are investigating reports or problems accessing the web site and placing phone calls.
Posted Feb 11, 2015 - 14:37 EST